IF YOU NEED HELP IN ENROLLING
Because of security concerns, our credit card processor is required to make certain changes to remain PCI compliant. This means:

1. Older operating systems such as Windows XP, Vista and 2003 Server are NOT going to be able to make encrypted connection to our servers to make orders and process credit cards.

2. Older browsers which use RC4 encryption are NOT going to be able to make encrypted connections to our servers to make orders or process credit cards.

WHAT CAN BE DONE?

You will need to:

1. Update the Windows Operating System to the latest Service Packs and Updates.

2. Download and install a newer web browser:
a. Firefox : http://www.getfirefox.com/
b. Chrome : (STOPPED Supporting XP as of Jan 2016)

3. Ensure browser TLS 1.2 Compliance:
a. https://www.ssllabs.com/ssltest/viewMyClient.html
b. https://www.howsmyssl.com/

4. Upgrade the Windows Operating System to Windows 7, 8, or 10

5. Switch to a MAC newer than 10.5

Sportsmen's Dog Training Club  BBB Business Review

FOUNDED 1942, Proud to be Michigan's Oldest Dog Training Club

-->